Корректировка записей регистров

Проблема переноса в "документ корректировка записей регистров"

Я
   manoff

Необходимо из нетиповой конфигурации перенести остатки из регистра накопленияв документ корректировка записей регистров УТ 10.3.
Проблема в том, что у него нет табличных частей соотвествующих конкретным регистрам. Соотвественно при настройке конвертаций свойст не могу понять как обратиться к параметрам которых нет:( В типовых примерах у конфигурации приемника есть соотвествующая табличная часть.
Подсказывайте, господа

 
 

   NcSteel

Пиши сразу в регистр.

Вообщето в УТ для переноса остатков существуют другие документы.

   Defender aka LINN

(0) Выгрузи метаданные, читая надписи на галках.

   manoff

В регистр, идея неплохая, но хотелось бы сделать культурно. (2) Намек понял, попробую

   zbv

(3) а что не культурного, в том чтобы записать данные в регистр, назначив регистратором документ "Корректировка записей регистров" ?

«Корректировка записей регистров» и другие способы редактирования записей

учитывая, что это единственный способ использовать документ "Корректировка записей регистров"

   manoff

(2) Спасибо, отдельное. именно это я и не доглядел. Остальным просто спасибо за участие.

   manoff

Кстати в догонку вопрос, почему может не ставиться галка Автоматически генерировать номер или код в ПКО. Ставлю, нажимаю записать — убирается.

   manoff Ребята, посмотрите еще конструкцию Если Объект.ВидКарты = Перечисления.ВидыИнформационныхКарт.Штриховая Тогда ЗаписьШтрихкода = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи(); ЗаписьШтрихкода.Владелец = Объект.Ссылка; ЗаписьШтрихкода.ТипШтрихкода = Объект.ТипШтрихкода; ЗаписьШтрихкода.Штрихкод = Объект.КодКарты; Попытка ЗаписьШтрихкода.Записать(Истина); Исключение Отказ = Истина; Сообщить(ОписаниеОшибки()); КонецПопытки; КонецЕсли; Поставил ее в обработчик после загрузки Элемента Справочника Информационные карты. Не отрабатывает — ругается что Владелец пустой. Пришел к выводу, что это по причине того что после загрузки элемент еще не записан и соотвественно ссылки как таковой нет. Ткните носом, как бы это разрулить.    GenV

(7) Я бы добавил выгрузку записи в регистры сведений на этапе выгрузки в ПослеВыгрузки у источника. Через ВыгрузитьПоПравилу и ВходящиеДанные.

Как пример — выгрузка контактной информации в демо базе КД.

Попробуйте новый бесплатный сервис для быстрого анализа кода типовых конфигураций 1c-api.com

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Корректировка записей в регистре накопления

Я
   doublenick Подскажите, плиз.

Есть заполненный регистр накопления, туда добавлено НовоеПоле (измерение). Как без повторного проведения документов обновить записи регистра, чтобы заполнить это новое поле?

НаборЗаписей = РегистрыНакопления.ВнутренниеЗаказы.СоздатьНаборЗаписей(); А дальше? 
     Любопытная НаборЗаписей.Отбор.Регистратор.Установить(СсылкаНаРегистратор); НаборЗаписей.Прочитать(); ТЗ = НаборЗаписей.Выгрузить(); ТЗ.ЗаполнитьЗначения(Значение, ИмяПоля); НаборЗаписей.Загрузить(ТЗ); НаборЗаписей.Записать(); Примерно так    Mort

Отбор.Регистратор.Установить()/Прочитать()/…./Записать()

   Serg_1960

🙂
Отбор/Выгрузить/(изменить)/Загрузить/Записать — читать необязательно, а вот Удалить исходное, как мне кажется, — надо.

   Serg_1960 Имхо, если автора понимать буквально, то работу срегистром надо начинать с запроса. Типа вот так:

    Запрос = Новый Запрос();     Запрос.Текст =     "ВЫБРАТЬ РАЗЛИЧНЫЕ     |    ВашРегистр.Регистратор КАК Регистратор     |ИЗ     |    РегистрНакопления.ВашРегистр КАК ВашРегистр";          Выборка = Запрос.Выполнить().Выбрать();          НаборЗаписей = РегистрыНакопления.ВашРегистр.СоздатьНаборЗаписей();          Пока Выборка.Следующий() Цикл                  НаборЗаписей.Отбор.Регистратор.Установить(Выборка.Регистратор);                  ВсеЗаписи = НаборЗаписей.Выгрузить();         … в цикле или как-то по другому изменить записи …

Корректировка записей регистров в 1С с помощью документа Операции или из проводок

        НаборЗаписей.Загрузить(ВсеЗаписи);         НаборЗаписей.Записать();              КонецЦикла;

   doublenick В общем, сделал так. Всем спасибо.
    ВыборкаДокументов = Документы.ВнутреннийЗаказ.Выбрать();          Пока ВыборкаДокументов.Следующий() Цикл                  НаборЗаписей = РегистрыНакопления.ВнутренниеЗаказы.СоздатьНаборЗаписей();         НаборЗаписей.Отбор.Регистратор.Установить(ВыборкаДокументов.Ссылка);         НаборЗаписей.Прочитать();                  Для Каждого Запись Из НаборЗаписей Цикл               Запись.клПодразделениеПотребитель = Запись.ВнутреннийЗаказ.ПодразделениеИсполнитель;         КонецЦикла;                      НаборЗаписей.Записать();              КонецЦикла;    Mankubus

(5) в (4) лучше код, у вас выбираются даже не проведенные документы

   doublenick

(6) Согласен — но у меня они все проведены)

   Serg_1960

(7) Методически правильнее алгоритм "от регистратора", а не от документа. Вы не озвучили конфигурацию, поэтому рекомендую убедиться что ВнутреннийЗаказ — это единственный документ-регистратор у этого регистра. Что скорее всего не так, — у меня, например, 14 типов документов являются регистраторами для ВнутренниеЗаказы.

   doublenick

(8) Я сначала тоже об этом подумал, но, не вдаваясь в тонкости конфигурации, результат однозначно правильный — что через регистратор, что через измерение ВЗ.

TurboConf 5 — расширение возможностей Конфигуратора 1С

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

1С 8.2 УП : Документ Корректировка записей регистров — Как программно создать и заполнить?

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *