Обновление индекса ППД

1С регламентные и фоновые задания

1С Предприятие имеет в своих конфигурациях регламентные и фоновые задания. Эти задания выполняются по планировщику с учетом расписания для каждого задания. Некоторые из заданий выполняются изначально по таймеру через определенное количество секунд, что может негативно сказываться на производительности и явно мешать работе в информационной базе.

Для редактирования регламентных и фоновых задач в вкладке администрирование нужно выбрать слева  «регламентные и фоновые задания».

1С регламентные и фоновые задания

Появится список уже существующих заданий, их состояние, расписание и другая информация.

Кликнув пару раз на любое из заданий откроется окно со свойствами этого задания. Тут можно изменить множество настроек на свой вкус, включая расписание выполнения этой задачи. Для отключения задачи нужно снят флажок «Включено». Но если задача должна выполнять по расписанию крайне важно использовать отдельного пользователя с полными правами для всех фоновых задач.

Параметры расписания выполнения задач очень гибкие, но все же желательно выставить все задачи таким образом чтобы одновременно выполнялась только 1 задача и желательно в нерабочее время. Исключением может быть только синхронизация нескольких смежных информационных баз, например бухгалтерия предприятия + зарплата и управление персоналом.

Загрузка классификатора банков — воскресение, 4:30
Загрузка курсов валют — каждый день; 7:00
Извлечение текстов — каждый день; 6:00.
Обмен сообщениями по учетным записям документооборота — каждый день; каждые 10800 сек.
Обновление агрегатов — каждый день; с 5:00:00 один раз в день
Обновление Задач Бухгалтера — каждый день; с 6:30:00 один раз в день
Обновление индекса ППД (полнотекстового поиска) — каждый день; каждые 10800 сек.
Перестроение агрегатов — каждый день, по дням недели ; с 3:00:00 один раз в день
Пересчет текущих значений относительных дат запрета изменения — каждый день; с 7:00:00 один раз в день
Слияние индекса ППД (полнотекстового поиска) — каждый день; с 4:00:00 один раз в день
Удаление неактуальной информации синхронизации — каждый день; с 3:30:00 один раз в день
Установка периода рассчитанных итогов — каждый день, 5-го числа месяца; с 1:00:00 один раз в день

Рассказать:

v8: Как остановить службу полнотекстового поиска

Я
   misha122062

сабж
Говорят есть обработка на ИТС. Облазил весь диск но не нашел. Кто в курсе — как называется она?

 
 

   notton

jobconsole

   пента

а через меню операции пробовал ?

   360i

Через конфигуратор (0)

   Рэйв

(0)Операции->Управление полнотекстным поиском->Настройка->галка "Разрешить полнотекстный поиск"

   misha122062

(1)Там все обработки по русски называются вроде — как по русски то?
(3)Где конкретно

   misha122062

(4)А это действует на всех пользователей?
Мне надо сделать для всех — но пароли всех я не знаю.
Вот и говорят — есть обработка которая для всех блокирует

   Рэйв

(6)Вроде на всех. Сам не проверял. Убери и посмотри под другим юзером.

   misha122062

понял.
Обработку нашел — "консоль заданий".
Только  там 2 вещи — Обновление индекса полнотекстового поиска и слияние индекса полнотекстового поиска.

Полнотекстовый поиск в 1С (что это и пример использования)

Обе что ли останавливать.

   Рэйв

(8)Зачем тебе что-то делать с индексами если у тебя задача отключить службу совсем?

   misha122062

Совсем остановить там в обработке нет. Это есть в  Операции->Управление полнотекстным поиском.
Только вопрос — а будет ли работать ГЛОБАЛЬНЫЙ ПОИСК по конфигурации — т.е. в конфигураторе

 
 

   hhhh

(10) а ты веришь, что глобальный поиск через полнотекстовый сделан?

   Рэйв

(10)Будет.

   misha122062

(11)не верил,  но просто сомнения взяли. Для чего полнотекстовый то я знаю — тока им не пользуются.
(12)спасибо.
Т.е. вообще отключить полнотекстовый поиск можно только из Операции->Управление полнотекстным поиском? Так?

   Рэйв

(13)Может еще как можно, но так проще всего.

   hhhh

(13) да вообще-то можно его вообще не отключать. Просто сделать так, чтобы обновление индекса автоматически не запускалось. Например, создать специального пользователя для обновления индекса.

   misha122062

(15)т.е. если я просто очищу индекс и отключу его автоматическое обновление — все ОК?

   hhhh

(15) ИМХО, тормоза происходят, в основном, когда запускается обновление индекса. Сам поиск реально нигде не используется.

   misha122062

Поставил в Операции->Управление полнотекстным поиском очистка индекса — но вывалил ошибку — "Очистка индекса невозможна пока идет его построение. Остановите индексирование и повторите попытку."
Но! Я в заданиях все задания по индексированию остановил!
В чем дело то?

   Рэйв

(18)Сними сессию фоного задания на сервере 1С..Если скуль конечно.

   misha122062

(19)нет фоновых заданий в том то и дело!
получается никак не могу очистить индекс. Т.е. остановить могу, а очистить — нет

TurboConf 5 — расширение возможностей Конфигуратора 1С

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Программирование

Обновление индекса полнотекстового поиска

Подробности Категория: Програмирование 1С Опубликовано 21.04.2015

Начиная с платформы 8.3.5.1068 компания 1С переработала принцип поиска в динамическом списке.

Виснет при обновление индекса полнотекстного поиска

Теперь поиск производится по полнотекстовому поиску при выполнении следующих условий:

  • Полнотекстовый поиск разрешен для конфигурации (проверить можно в операции — управление полнотекстовым поиском)
  • Полнотекстовый поиск разрешен для объекта (в свойствах объекта должно быть указано использовать в соответствующем разделе)
  • В результате поиска не произошло ошибки.

Если условия не выполняются то поиск производится силами СУБД (более тяжелый случай в вопросе потребления мощностей).

Возникает вопрос об актуальности индекса, который состоит из двух частей. Если данные заводились после обновления индекса то при поиска вы получите не все данные или вообще пустой список. Поэтому индекс должен быть актуальным на сколько это возможно. В типовых конфигурациях, построенных на БСП, для этого используется 2 регламентных задания ОбновлениеИндексаППД и СлияниеИндексаППД. Первое запускается каждую минуту, второе раз в сутки для слияния 2 индексов.

Я не использую БСП и поэтому вырвал кусочек необходимый для работы полнотекстового поиска. Создаем в конфигурации Общий модуль и заполняем его кодом:

// Обновляет индекс полнотекстового поиска.Процедура ОбновлениеИндексаППД&#40;&#41;Экспорт   ОбновитьИндекс&#40;НСтр&#40;"ru = ‘Обновление индекса ППД’"&#41;,Ложь,Истина&#41;;   КонецПроцедуры   // Обработчик регламентного задания.Процедура СлияниеИндексаППДПоРасписанию&#40;&#41;Экспорт   СлияниеИндексаППД&#40;&#41;;   КонецПроцедуры   // Общая процедура для обновления и слияния индекса ППД.Процедура ОбновитьИндекс&#40;ПредставлениеПроцедуры, РазрешитьСлияние =Ложь, Порциями =Ложь&#41;   ЕслиНЕ ОперацииРазрешены&#40;&#41;ТогдаВозврат;КонецЕсли;   ЗаписьЖурнала&#40;Неопределено,НСтр&#40;"ru = ‘Запуск процедуры ""%1"".’"&#41;,, ПредставлениеПроцедуры&#41;;   Попытка ПолнотекстовыйПоиск.ОбновитьИндекс&#40;РазрешитьСлияние, Порциями&#41;; ЗаписьЖурнала&#40;Неопределено,НСтр&#40;"ru = ‘Успешное завершение процедуры ""%1"".’"&#41;,, ПредставлениеПроцедуры&#41;;Исключение ЗаписьЖурнала&#40;Неопределено,НСтр&#40;"ru = ‘Ошибка выполнения процедуры ""%1"":’"&#41;, ИнформацияОбОшибке&#40;&#41;, ПредставлениеПроцедуры&#41;;КонецПопытки;   КонецПроцедуры   // Возвращает разрешены ли операции полнотекстового поиска: обновление индексов, очистка индексов, поиск.Функция ОперацииРазрешены&#40;&#41;Экспорт   Возврат ПолнотекстовыйПоиск.ПолучитьРежимПолнотекстовогоПоиска&#40;&#41;= РежимПолнотекстовогоПоиска.Разрешить;   КонецФункции   // Создает запись в журнале регистрации и сообщениях пользователю;//   Поддерживает до 3х параметров в комментарии при помощи функции.//   СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку.//   Поддерживает передачу информации об ошибке, подробное представление//   ошибки добавляется в комментарий записи в журнал регистрации.//// Параметры://   УровеньЖурнала — УровеньЖурналаРегистрации — Важность сообщения для администратора.//   КомментарийСПараметрами — Строка — Комментарий, который может содержать параметры %1, %2 и %3.//   ИнформацияОбОшибке — ИнформацияОбОшибке, Строка — Информация об ошибке, которая будет размещена после комментария.//   Параметр1 — Строка — Для подстановки в КомментарийСПараметрами вместо %1.//   Параметр2 — Строка — Для подстановки в КомментарийСПараметрами вместо %2.//   Параметр3 — Строка — Для подстановки в КомментарийСПараметрами вместо %3.//Процедура ЗаписьЖурнала&#40;УровеньЖурнала = Неопределено, КомментарийСПараметрами ="", ИнформацияОбОшибке = Неопределено, Параметр1= Неопределено, Параметр2= Неопределено, Параметр3= Неопределено&#41;   // Определение уровня журнала регистрации на основе типа переданного сообщения об ошибке.ЕслиТипЗнч&#40;УровеньЖурнала)<>Тип&#40;"УровеньЖурналаРегистрации"&#41;ТогдаЕслиТипЗнч&#40;ИнформацияОбОшибке&#41;=Тип&#40;"ИнформацияОбОшибке"&#41;Тогда УровеньЖурнала = УровеньЖурналаРегистрации.Ошибка;ИначеЕслиТипЗнч&#40;ИнформацияОбОшибке&#41;=Тип&#40;"Строка"&#41;Тогда УровеньЖурнала = УровеньЖурналаРегистрации.Предупреждение;Иначе УровеньЖурнала = УровеньЖурналаРегистрации.Информация;КонецЕсли;КонецЕсли;   // Комментарий для журнала регистрации. ТекстДляЖурнала = КомментарийСПараметрами;Если Параметр1<> Неопределено Тогда ТекстДляЖурнала = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку&#40; ТекстДляЖурнала, Параметр1, Параметр2, Параметр3&#41;;КонецЕсли;ЕслиТипЗнч&#40;ИнформацияОбОшибке&#41;=Тип&#40;"ИнформацияОбОшибке"&#41;Тогда< ТекстДляЖурнала = ТекстДляЖурнала +Символы.ПС + ПодробноеПредставлениеОшибки&#40;ИнформацияОбОшибке&#41;;ИначеЕслиТипЗнч&#40;ИнформацияОбОшибке&#41;=Тип&#40;"Строка"&#41;Тогда ТекстДляЖурнала = ТекстДляЖурнала +Символы.ПС + ИнформацияОбОшибке;КонецЕсли; ТекстДляЖурнала =СокрЛП&#40;ТекстДляЖурнала&#41;;   // Запись в журнал регистрации. ЗаписьЖурналаРегистрации&#40;НСтр&#40;"ru = ‘Полнотекстовое индексирование’",&#41;,  УровеньЖурнала,,,  ТекстДляЖурнала&#41;;КонецПроцедуры   // Выполняет слияние индексов полнотекстового поиска.Процедура СлияниеИндексаППД&#40;&#41;Экспорт   ОбновитьИндекс&#40;НСтр&#40;"ru = ‘Слияние индекса ППД’"&#41;,Истина&#41;;   КонецПроцедуры  

Добавляем 2 регламентных задания. Первое запускается каждые 60 сек и ссылается на ОбновлениеИндексаППД(), второе раз в сутки ночью и выполняет СлияниеИндексаППД().

Через минут 20 после обновления конфигурации у меня снова заработал быстрый поиск по строке.

Тормоза при обновлении индекса полнотекстового поиска

Я
   fisher Есть самописка на УФ на БСП 2.2Обновление ППД штатно каждую минуту (слияние — раз в сутки). В нормальной ситуации если нет пакетных обновлений отрабатывает за секунду. И всё было хорошо.
А тут пару дней заметил, что при отсутствии изменений данных по несколько минут крутит (в итоге получается что фоновое постоянно крутится). Очистил, пересчитал, сделал слияние — некоторое время работало нормально. Потом опять началось…
Лишнего не индексировал, размер 3 гига с хвостиком.
Что за болезнь? Кто сталкивался? Как лечить?
 
     D_E_S_131

Надо же, оказывается есть люди, которые пользуются этим "полнотекстовым поиском"…

   fisher

(1) Ты хотел сказать, пользуются "Такси"?

Проблема с выполнением регламентного задания УТ 11 #789608

Он там гвоздями прибит. Ну и когда работает — отличная штука 🙂

   fisher

После ночного слияния индекса ППД пока полет нормальный. Будем посмотреть…

   vde69

(1) я пользуюсь, очень крутая вещь…
(0) скорее всего у тебя какие-то фоновые задания мешают.

начни с определения повторяемости ситуации (определи максимум параметров при которых ситуация повторяется), потом отключай и смотри

зы
память на сервере 1с посмотри, может там проблеммы

   fisher

(4) Не. Я это наживую мониторил. Ничего в это время параллельно не шуршит. А если параллельно пакетная заливка какая-нить длительная, то обновление ППД отваливается с ошибкой. По памяти хороший запас — от половины до двух третей.
Не исключаю выбрыки сервера приложений. Он под линухом более капризный. У меня пока еще 8.3.5.1186 стоит. Если две-три недели не перегружать — начинаются заморочки. Поэтому раз в неделю перегружаем. И то пришлось переключить в режим отдельных рабочих процессов по базам, потому что еще хуже было.
Но пока с утра без приколов…

   fisher

Ну и кстати да — механизмы поиска на Такси в динамических списках (с ППД) фактически являются идеальными. Я не могу придумать, чего там можно еще захотеть.

Попробуйте новый бесплатный сервис для быстрого анализа кода типовых конфигураций 1c-api.com

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *