Ошибка при выполнении запроса post

Ошибка при выполнении запроса POST к ресурсу /e1cib/logForm:

Я
   freelog Всем добрый день!
Помогите, пожалуйста, с проблемой. Возникает во время обмена УТ 11.1 => БП 2.0, а конкретно во время загрузки КОНТРАГЕНТОВ в БП.

Ошибка выполнения запроса
Ошибка при выполнении запроса POST к ресурсу /e1cib/logForm:
по причине:
На сервере 1С:Предприятия произошла неисправимая ошибка. Приложение будет закрыто

Конфигурацию обновил до последнего релиза.
Платформа тоже последняя.
ТИИ делал.

1С:Предприятие 8.3 (8.3.8.2322) Бухгалтерия предприятия, редакция 2.0 (2.0.66.12) 
     xpenaten

УТ. Ошибка при выполнении запроса POST к ресурсу /e1cib/logForm:

   H A D G E H O G s

При заведении контрагента, его реквизит скопировали с сайта через буфер обмена, в результате туда попал недопустимый символ XML.
Скорее всего причина в этом.

   freelog

(1)все смотрел — не помогло, к тому же забыл сказать, что база СЕРВЕРНАЯ
(2)хорошая мысль! а обойти это на этапе загрузки данных как-то можно?

В 1С Ошибка при выполнении запроса POST к ресурсу e1cib/login, что делать?

или только перелопачивать реквизиты контрагентов в базе источнике в недопустимых символов, чистить их и потом по новой выгружать?

   H A D G E H O G s (3) Найти в стэке процедуру, через которую проходят все данные и натравить на них
Функция ЗаменитьНедопустимыеСимволы(Текст) Экспорт     ПозицияСимвола=1;     Пока Истина Цикл         ПозицияСимвола=НайтиНедопустимыеСимволыXML(Текст,ПозицияСимвола);         Если ПозицияСимвола=0 Тогда             Прервать;         КонецЕсли;         Текст=Сред(Текст,1,ПозицияСимвола-1)+"&"+Строка(КодСимвола(Сред(Текст,ПозицияСимвола,1)))+Сред(Текст,ПозицияСимвола+1);     КонецЦикла; КонецФункции    freelog

После долгих мучений, экспериментальным путем было выявлено, что ошибка возникает только с базой в СЕРВЕРНОМ формате работы. С файловой базой на той же платформе проблем при обмене нет.
Предположу, что все-таки дело не в недопустимых символах, иначе бы ошибка вылезала в обоих случаях. Но на всяк случай перелопатил обработкой все реквизиты Контрагентов в базе-исходнике, но недопустимых символов не нашел.
Платформы перепробовал уже самые разные, начиная от 8.3.8.1747 и заканчивая тестовой 8.3.10.1877.
Друзья, есть еще какие-либо мысли на сей счет?

   freelog

up
коллеги, есть еще какие-нить идеи ? ну пичалька совсем с этим багом…

   lexx256

Такая же ошибка (На сервере 1С:Предприятия произошла неисправимая ошибка. Приложение будет закрыто) появлялась при выполнении длительных серверных вызовов. Связана вероятно с тем, что при таких вызовах процессы rphost отъедают всю доступную им память. Сняли ограничение на количество оперативки на рабочий процесс и проблема исчезла.

   freelog

(7) А где конкретно это ограничение снимается, можно поподробнее? в 1С, на SQL сервере, в ОСи ?

   lexx256

В настройках сервера 1С

   freelog

(9) не помогло (

 
 

   rphosts

(2) или что-то пытались передать на клиента несериализуемое
(5) потому что эмуляция сервера не полностью эквивалентна клиентсерверной ИБ
(7) мы такие

Попробуйте новый бесплатный сервис для быстрого анализа кода типовых конфигураций 1c-api.com

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

   Strimteam Обновил через поддержку конфигурацию УТ до версии 11.0.7.8. После запуска получаю "Невосстановимая ошибка Ошибка при выполнении запроса POST к ресурсу /e1cib/misc:
по причине:
Ошибка SDBL:
Ожидается имя таблицы (pos=19)" Версия 1С — 8.2.15.289. При обработке утилитой chdbfl — ошибок нет При реструктуризации — падает в дамп Выгрузку и загрузку ДТ делал- мимо.
При попытке снять с поддержки конфу — пишет что при обновлении критическая ошибка (ну и не обновляет собственно).

Что ещё попробовать?
 
 

   Strimteam

Сори опечатался — при проверке логической целостности падает в дамп

   andrewks

кэш чистил?

   Maxus43

бэкапа видимо нет…

   Strimteam бекапа нет кэш пользователя в C:\Users\User\AppData\Local\1C чистил    Strimteam при реструктуризации выдаёт следующее"В процессе обновления информационной базы произошла критическая ошибка.
по причине:
Ошибка SDBL:
Таблица или поле PredefinedID не содержится в разделе FROM (pos=67)"    Inform

(0) Обратно откатиться к предыдущему релизу УТ не предлагать?

   Strimteam

Если взять пересчёт итогов — пишет:
Ошибка SDBL:
В схеме базы данных нет таблицы с именем AccumRgOpt9137

   Strimteam

(6) — обновлялся через поддержку в конфиге. Если есть методы откатиться — буду рад.

   Inform

(8) в конфигураторе: Конфигурация — Загрузить конфигурацию из файла и подпихни старый cf. Он вроде даже спросит вставать ему на поддержку или нет…

   Maxus43

дак при реструктуризации что?

 
 

   DrShad

вообще-то уже 11.0.7.13

   Strimteam (10) — "В процессе обновления информационной базы произошла критическая ошибка.
по причине:
Ошибка SDBL:
Таблица или поле PredefinedID не содержится в разделе FROM (pos=67)"
(11) — конфа даже с поддержки не снимается. А уж при попытке обновиться до след версии — то же самое (критическая ошибка обновления).    Strimteam

(9) — сейчас попробую

   Strimteam

Обновил демку до этой версии. При сравнении конфигураций не выводит различий.

   Strimteam

(9) — не собственно на любые конфиги не хочет обновляться. Пишет критическая ошибка обновления.

   Inform (15) почисть %AppData%\1C\1Cv82только предварительно сохранив и перезайди в конфигуратор погляди.
Потом вернешь в случае чего…    Strimteam

(16) — всё то же самое

   Inform

(15) хм, а на пользовательском сайте уже начиная с УТ 11.0.7.3:
Внимание! Текущая версия конфигурации "Управление торговлей", редакция 11 предназначена для использования с версией системы 1С:Предприятие 8.2 не ниже 8.2.14.537.

Так что обновляй платформу и читай доки…

   Strimteam

Обновил само собой платформу — в первом посте написал. Платформа и так самая последняя

   Inform

в первом посте Версия 1С — 8.2.15.289

   Inform

(20) ааа, все перепутал

   Strimteam

Ну какие есть ещё идеи — чем можно её попытаться полечить?

   andrewks

на другой комп скопировать и там открыть пробовал?

   Strimteam

(23) — такой же вариант

   Inform

(24) отправляй в саппорт 1С пока время идет.
Еще какие варианты (сомнительно):
+ попробовать не снимать с поддержки конфигурацию, а выбрать "Редактируется с сохранением поддержки", если получится — накатить старый релиз, если не прокатит — выбрать это для каких-нить объектов — попробовать их поменять / сохранить
+ попробовать развернуть хранилище старой версии УТ, попробовать к нему поцепляться
+ можно попробовать развернуть базу в КС режиме, развернуть пустую рабочую базу и пообъединять

   Strimteam

Вобщем исправл(ось), так что если кому нужно — на заметку.
Так как dt  смог выгрузиться, то попробовал его залить в старую версию 1с 8.2
Взял 8.2.13.249, создал пустую и закинул туда этот дт-шник. Конфа встала, но при запуске ругалась уже не на критические ошибки ИБ, а на код (значит как минимум началась отладка). После чего принудительно снял с поддержки и накатил конфигурацию 11.0.6.9. Конфигурация встала. дальше запустил под этой же версией 1с 8.2 ИБ — запустилось.

Ошибка при выполнении запроса POST к ресурсу /e1cib/logForm:

Перезашёл в конфиг под 8.2.15.289, перевёл, запустил ИБ — и вуа ля, база жива и здорова. Что это было — знают только разрабы. Но если вдруг кому пригодиться — буду рад (хоть не будете тра..ть мозг как я) 🙂

Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Ошибка при выполнении запроса POST к ресурсу /e1cib/logForm:

Я
   freelog Всем добрый день!
Помогите, пожалуйста, с проблемой. Возникает во время обмена УТ 11.1 => БП 2.0, а конкретно во время загрузки КОНТРАГЕНТОВ в БП.

Ошибка выполнения запроса
Ошибка при выполнении запроса POST к ресурсу /e1cib/logForm:
по причине:
На сервере 1С:Предприятия произошла неисправимая ошибка. Приложение будет закрыто

Конфигурацию обновил до последнего релиза.
Платформа тоже последняя.
ТИИ делал.

1С:Предприятие 8.3 (8.3.8.2322) Бухгалтерия предприятия, редакция 2.0 (2.0.66.12) 
     xpenaten

УТ. Ошибка при выполнении запроса POST к ресурсу /e1cib/logForm:

   H A D G E H O G s

При заведении контрагента, его реквизит скопировали с сайта через буфер обмена, в результате туда попал недопустимый символ XML.
Скорее всего причина в этом.

   freelog

(1)все смотрел — не помогло, к тому же забыл сказать, что база СЕРВЕРНАЯ
(2)хорошая мысль! а обойти это на этапе загрузки данных как-то можно? или только перелопачивать реквизиты контрагентов в базе источнике в недопустимых символов, чистить их и потом по новой выгружать?

   H A D G E H O G s (3) Найти в стэке процедуру, через которую проходят все данные и натравить на них
Функция ЗаменитьНедопустимыеСимволы(Текст) Экспорт     ПозицияСимвола=1;     Пока Истина Цикл         ПозицияСимвола=НайтиНедопустимыеСимволыXML(Текст,ПозицияСимвола);         Если ПозицияСимвола=0 Тогда             Прервать;         КонецЕсли;         Текст=Сред(Текст,1,ПозицияСимвола-1)+"&"+Строка(КодСимвола(Сред(Текст,ПозицияСимвола,1)))+Сред(Текст,ПозицияСимвола+1);     КонецЦикла; КонецФункции    freelog

После долгих мучений, экспериментальным путем было выявлено, что ошибка возникает только с базой в СЕРВЕРНОМ формате работы. С файловой базой на той же платформе проблем при обмене нет.
Предположу, что все-таки дело не в недопустимых символах, иначе бы ошибка вылезала в обоих случаях. Но на всяк случай перелопатил обработкой все реквизиты Контрагентов в базе-исходнике, но недопустимых символов не нашел.
Платформы перепробовал уже самые разные, начиная от 8.3.8.1747 и заканчивая тестовой 8.3.10.1877.
Друзья, есть еще какие-либо мысли на сей счет?

   freelog

up
коллеги, есть еще какие-нить идеи ? ну пичалька совсем с этим багом…

   lexx256

Такая же ошибка (На сервере 1С:Предприятия произошла неисправимая ошибка. Приложение будет закрыто) появлялась при выполнении длительных серверных вызовов.

Ошибка при выполнении запроса POST к ресурсу /e1cib/logForm

Связана вероятно с тем, что при таких вызовах процессы rphost отъедают всю доступную им память. Сняли ограничение на количество оперативки на рабочий процесс и проблема исчезла.

   freelog

(7) А где конкретно это ограничение снимается, можно поподробнее? в 1С, на SQL сервере, в ОСи ?

   lexx256

В настройках сервера 1С

   freelog

(9) не помогло (

 
 

   rphosts

(2) или что-то пытались передать на клиента несериализуемое
(5) потому что эмуляция сервера не полностью эквивалентна клиентсерверной ИБ
(7) мы такие

Наведи порядок в своей работе используя конфигурацию 1C "Управление IT-отделом 8"

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.

Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *